Results 1 to 6 of 6
  1. #1
    Senior Member
    Join Date
    Dec 2013
    Posts
    108

    BUG: ice_cache.db gets deleted when I open Favorites

    For some reason the current version of ice films deletes the ice_cache.db file when I try to go into Favorites from the add-on. Luckily I have a backup copy, but right now Favorites is unusable since it just gets re-deleted when you try to use it.


  2. #2
    Plus the view options keep resetting to `media info 2` no matter how many times it is changed.

  3. #3
    Team TV ADDONS Developer
    Join Date
    May 2012
    Posts
    3,392
    See release post - Icefilms 1.99.50 Beta

    It's just being moved to a more proper location when Icefilms starts, one where that nice little Indigo service won't touch

    If it's not being copied over properly then let me know

  4. #4
    Senior Member
    Join Date
    Dec 2013
    Posts
    108
    Quote Originally Posted by Eldorado View Post
    See release post - Icefilms 1.99.50 Beta

    It's just being moved to a more proper location when Icefilms starts, one where that nice little Indigo service won't touch

    If it's not being copied over properly then let me know
    OK I found the new destination folder under \userdata\addon_data\plugin.video.icefilms and there was an ice_cache.db file there but it was an empty db file. So I deleted it, put my copy back in the original location of \Kodi\cache then reopened Ice Films and went into favorites. The file is being moved BUT only as an EMPTY copy. None of the data from the file is moved over. My copy of ice_cache.db is 125KB but after the move it's only 26kb and none of the favorites are in it anymore.

    That said, now that I know the new location, if I put my copy in there directly, then it stays and it works fine. However, the move process should probably get fixed asap to prevent some angry "customers" that do not happen to have backups of their favorites.

  5. #5
    Team TV ADDONS Developer
    Join Date
    May 2012
    Posts
    3,392
    Got this fixed.. damn stupid mistake on my part, tried to copy the DB after it initializes in the new location when it should have been copying first

    Hopefully this didn't screw too many people up!

    Also instead of delete I just renamed the original, but if you have that Indigo installed it's automatic service will wipe out your cache/temp folder anyways... sigh...

  6. #6
    Senior Member
    Join Date
    Dec 2013
    Posts
    108
    Excellent news.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •